Shopify incident impacting Locksmith's storefront API

Incident Report for Locksmith

Resolved

Shopify has updated their status page:

> A fix for this issue has been implemented and is now being monitored.

We're closing our incident report for this. If you continue to see issues with this sort of thing, please check https://www.shopifystatus.com/ or contact Shopify support. If you have questions about impact to your Locksmith account, please email team@uselocksmith.com.
Posted Jan 19, 2024 - 19:43 UTC

Monitoring

We're seeing recovery from this across multiple stores. We'll keep this incident report open until Shopify confirms resolution on their status page.
Posted Jan 19, 2024 - 19:25 UTC

Update

Shopify has publicly confirmed the incident via their status page:

https://www.shopifystatus.com/incidents

> Some apps may not be functioning as expected
> Users may experience issues with some apps, due to some app proxies not receiving customer data as expected. We are investigating this issue, and will post further updates as soon as possible.
Posted Jan 19, 2024 - 18:45 UTC

Identified

Shopify has acknowledged an incident that is preventing Locksmith's storefront API from inspecting the logged-in customer. This impacts stores that are using Locksmith's storefront API to authorize logged-in customers, and results in customers being unable to access content that they are qualified for.

This issue impacts all apps, from what we can tell. Shopify is aware of the issue, and they're investigating.

This incident does not impact stores that are not using Locksmith's storefront API. In all other contexts, Locksmith is still able to access and inspect the logged-in customer.

https://www.locksmith.guide/developer-tools/locksmith-storefront-api
Posted Jan 19, 2024 - 17:57 UTC
This incident affected: Locksmith.