Interruption to Locksmith-powered customer login buttons

Incident Report for Locksmith

Resolved

This incident has been resolved.
Posted Oct 24, 2024 - 21:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 23, 2024 - 18:01 UTC

Update

We have deployed a workaround so that login links show customers the login page as expected. Press "Update Locksmith" from the Help tab within the app if you do not see this in action on your store. However, redirects back to the locked content after signing in are still not functioning. We remain in contact with Shopify support to try to find a more permanent fix for redirecting customers back to their locked content after signing in.
Posted Oct 22, 2024 - 13:07 UTC

Identified

⭐️ This incident is only relevant for stores using Shopify's "new" customer accounts, and for Locksmith configurations which show users a login button. ⭐️

Shopify's login redirect functionality has changed, interrupting Locksmith's ability to prompt customers for login and then redirect the customers back to the desired content afterwards. Affected stores will see the login button redirecting customers to the current page _without_ a login prompt; customers might experience this as the button not doing anything at all.

We're getting in touch with Shopify, and we're looking for the best way forward. :)
Posted Oct 21, 2024 - 22:55 UTC
This incident affected: Locksmith.