Shopify incident impacting Shopify stores, including Locksmith's storefront API and Locksmith app UI

Incident Report for Locksmith

Resolved

Shopify has resolved this issue and is continuing to monitor to ensure platform stability.
Posted Apr 02, 2025 - 05:08 UTC

Monitoring

We're seeing recovery from this across multiple stores in the storefront and Locksmith app UI. We'll keep this incident report open until Shopify confirms resolution on their status page.
Posted Apr 02, 2025 - 03:38 UTC

Update

Shopify has publicly confirmed the incident via their status page:

https://www.shopifystatus.com/incidents

Multiple Shopify services are not loading. Shopify is investigating an error where merchants, customers, and partners may experience issues when trying to access Shopify services.
Posted Apr 02, 2025 - 03:37 UTC

Investigating

Shopify appears to be experiencing an incident that is preventing Locksmith's storefront API from inspecting the logged-in customer, and validating remote key condition.

This issue impacts all apps, from what we can tell.
Posted Apr 02, 2025 - 03:23 UTC
This incident affected: Locksmith.