Service interruption

Incident Report for Locksmith

Resolved

This incident has been resolved.
Posted May 18, 2023 - 21:02 UTC

Monitoring

We've identified the issue, and have resolved it. We're monitoring for results.
Posted May 18, 2023 - 20:32 UTC

Investigating

Requests to uselocksmith.com are failing. We're investigating.
Posted May 18, 2023 - 20:27 UTC
This incident affected: Locksmith.